Bem Vindo ao SMAI

Bem Vindo

O Sistema para Manejo da Agricultura Irrigada SMAI é um software que tem por finalidade automatizar e simplificar o cálculo da Evapotranspiração de Referência diária pelo método Penman-Monteith FAO de forma a facilitar e padronizar a obtenção direta dos dados para o manejo da irrigação. O cálculo exige um alto nível de abstração em suas etapas e um conhecimento técnico específico. O software pode ser usado como uma ferramenta de auxílio para pesquisa acadêmicas ou até mesmo na extensão rural através do manejo da agricultura irrigada. Assim, o usuário tem a possibilidade de calcular a evapotranspiração diária individualmente ou em lote.

O software foi desenvolvido utilizando a linguagem de programação C#, é uma linguagem de programação orientada a objetos, desenvolvida pela Microsoft como parte da plataforma .NET. A sua sintaxe orientada a objetos foi baseada no C++ mas inclui muitas influências de outras linguagens de programação, como Object Pascal e Java.

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator

Copyright © by AHI. All Rights Reserved.


Introdução

Bem Vindo ao SMAI ››

Bem Vindo

O Sistema para Manejo da Agricultura Irrigada é um software que automatiza e simplifica o cálculo da Evapotranspiração de Referência diária pelo método Penman-Monteith FAO de forma a facilitar e padronizar a obtenção direta dos dados para o manejo da irrigação. O cálculo da evapotranspiração exige um alto nível de abstração em suas etapas e um conhecimento técnico mais específico. O software pode ser usado como uma ferramenta de auxílio para pesquisa acadêmicas ou até mesmo na extensão rural através do manejo da agricultura irrigada. Assim, o usuário tem a possibilidade de calcular a evapotranspiração diária individualmente ou em lote.

O software foi desenvolvido utilizando a linguagem de programação C#, é uma linguagem de programação orientada a objetos, desenvolvida pela Microsoft como parte da plataforma .NET. A sua sintaxe orientada a objetos foi baseada no C++ mas inclui muitas influências de outras linguagens de programação, como Object Pascal e Java.

Tela de Início

Created with the Personal Edition of HelpNDoc: Full featured Help generator


Evapotranspiração

Evapotranspiração

A evapotranspiração é a forma pela qual a água da superfície terrestre passa para a atmosfera no estado de vapor, tendo papel importantíssimo no ciclo hidrológico em termos globais. Esse processo envolve a evaporação da água de superfícies de água livre (rios, lagos, represas, oceano, etc), dos solos e da vegetação úmida (que foi interceptada durante uma chuva) e a transpiração dos vegetais.

Para suprir essa perda de água para atmosfera é necessário repor esta a fim de garantir um bom desenvolvimento das culturas. A reposição da água no solo pode ser de forma natural (chuva) ou artificial (irrigação).

Created with the Personal Edition of HelpNDoc: Full featured multi-format Help generator


O Que é?

Evapotranspiração ››

Evapotranspiração

A evapotranspiração é a forma pela qual a água da superfície terrestre passa para a atmosfera no estado de vapor, apresentando grande importância no ciclo hidrológico em termos globais. Esse processo envolve a evaporação da água de superfícies de água livre (rios, lagos, represas, oceano, etc), dos solos e da vegetação úmida (que foi interceptada durante uma chuva) e a transpiração dos vegetais.

Para suprir essa perca de água das plantas para atmosfera é necessário repor esta água perdida a fim de garantir um bom desenvolvimento das culturas. A reposição da água no solo pode ser de forma natural (chuva) ou artificial (irrigação).

O Sistema para Manejo da Agricultura Irrigada disponibiliza duas formas de se obter a evapotranspiração, sendo a potencial ou de referência (ETp ou ETo)e a da cultura (ETc).

A evapotranspiração de referência é a somatória da perda de água através da evaporação do solo e a transpiração das plantas tendo como referência a grama batatais (Paspalum notatum) com altura de 8 a 15 cm que recobre todo o solo e sem apresentar deficiência hídrica.

A evapotranspiração da cultura esta estritamente relacionada a evapotranspiração potencial sendo que esta leva em consideração o estágio de desenvolvimento da cultura.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Metodologia

Evapotranspiração ››

Metodologia

A evapotranspiração de referência foi determinar a partir do cálculo apresentado (Eq. 1) por Penman-Monteith-FAO (Allen et al, 1998).

(Eq. 1)

Onde:

ETo = Evapotranspiração de referência (mm.dia-1);

= Radiação líquida (MJ.m2.dia-1);

G = Densidade do fluxo de calor do solo (MJ.m2.dia-1);

T = Temperatura média do ar (ºC);

= Velocidade média do vento à altura de 2 m (m.s-1);

= Pressão do vapor de saturação (KPa);

= Pressão atual do vapor de água (KPa);

∆ = Declive da curva da pressão do vapor (KPa.ºC-1);

γ = Constante psicrométrica (KPa.ºC-1).

A evapotranspiração da cultura é determinada a partir da evapotranspiração de referência, porém levando em consideração o coeficiente de cultura (Kc) que varia de acordo com o estágio de desenvolvimento da cultura (Eq. 2). O coeficiente da cultura é um dado adimensional que é determinado experimentalmente para cada cultura pela relação ETc / ETo.

ETc = Kc . ETo (Eq. 2)

Onde:

ETc = Evapotranspiração da cultura (mm.dia-1);

Kc = Coeficiente de cultura;

ETo = Evapotranspiração de referência (mm.dia-1).

A estimativa da radiação líquida se dá através da equação 3.

Rn = Rns - Rnl (Eq. 3)

Rn = Radiação solar líquida (MJ.m2.dia-1);

Rns = Radiação solar de ondas curtas (MJ.m2.dia-1);

Rnl = Radiação solar de ondas longas (MJ.m2.dia-1).

A estimativa da pressão atmosférica se dá através da equação 4.

(Eq. 4)

P = Pressão atmosférica (KPa);

z = altitude acima do nível do mar (m).

Created with the Personal Edition of HelpNDoc: Full featured Help generator


Instruções e Funções

Instrumentações e funções

Neste ítem o usuário receberá informações de todos ícones e barras de ferramentas contidas no Sistema para Manejo da Agricultura Irrigada e suas respectivas funções, além dos diferentes tipos de processamento, assim, facilitando o manuseio ao mesmo.

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Barra de Ferramentas

Instruções e Funções ››

Barra de ferramentas"

Através da barra de ferramentas o usuário tem acesso a todas as funções do sistema.

Barra de Ferramentas

Botões

  • Efetua o cálculo da evapotranspiração, seja em lote ou individual;
  • Imprime a lista dos dados de entrada juntamente com o cálculo da evapotranspiração;
  • Salva as configurações locais como altitude e latitude;
  • Botão Ajuda, Exibe uma ajuda para que o usuário possa tirar todas suas dúvidas em relação ao Sistema para Manejo da Agricultura Irrigada.
  • Botão Sobre, Exibe informações como versão do software e seus respectivos desenvolvedores.
  • Botão Citar, Exibe uma tela que trazendo explicações de como fazer a citação do software.
  • Exibe o tipo de processamento a ser usado no cálculo da evapotranspiração, seja ele individual ou lote.
  • Fecha o aplicativo.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Como Citar

Instruções e Funções ››

Como Citar

Exemplo de como citar este software.

Citação

Exemplo de citação:

Acesso em 28 de Julho de 2011:

MARIANO, J. C. Q.; SANTOS, G. O.; HERNANDEZ, F. B. T. Sistema para Manejo da Agricultura Irrigada SMAI. versão 1.0. Disponível em: <http://clima.feis.unesp.br/smai>. Acesso em: 28 Jul 2011.

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Sobre

Instruções e Funções ››

Sobre

Créditos, informações do software e contacto dos autores.

Sobre

Os autores desenvolvem suas atividades na Área de Hidráulica e Irrigação UNESP Ilha Solteira através do Núcleo de Apoio Computacional a Irrigação onde se constitui de uma equipe multidisciplinar.

Jean Carlos Quaresma Mariano

Analista de Sistemas

Desenvolvedor da Área de Hidráulica e Irrigação UNESP Ilha Solteira

jeanquaresma@gmail.com

Gilmar Oliveira Santos

Engenheiro Ambiental

Mestrando em Agronomia UNESP Ilha Solteira

gilmar_engambiental@yahoo.com.br

Fernando Braz Tangerino Hernandez

Doutor em Agronomia

Professor Titular em Irrigação e Drenagem UNESP Ilha Solteira

fbthtang@agr.feis.unesp.br

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Tipo de Processamento

Instruções e Funções ››

Tipo de Processamento

O usuário poderá optar pelo processamento (cálculo da evapotranspiração em lote ou individual).

  • Individual: É possível efetuar o cálculo da evapotranspiração diária, ou seja, quando se tem dados de apenas um dia.

Tela de processamento Individual

  • Lote: Com este modo é possível calcular a evapotranspiração em um período de datas superior a um dia.

Tela de processamento em Lote

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Individual

Instruções e Funções ›› Tipo de Processamento ››

Processamento Individual

O usuário que optar pelo processamento individual da evapotranspiração de referência deve ser ter em mente que a entrada de dados se dá de forma manual, para isso deve-se seguir os passos abaixos.

Localização

A localização é referente ao local que a estação estação agrometereológica está instalada. A latitude pode ser informada em graus ou em radianos e a altitude em metros.

Localização

Período Analisado

Para calcular a evapotranspiração é necessário informar o período de análise. A data pode ser informada em formato Gregoriano ou Juliano. caso o usuário optar pela opção do dia Juliano, automaticamente a opção mês é bloqueada pelo sistema, em ambas as opções o ano é obrigatório.

Período

Variáveis Agroclimáticas

Neste modo as variáveis Agroclimáticas citadas abaixo são obrigatórias para efetuar o cálculo da evapotranspiração Penman-Monteith FAO:

  • Temperatura Máxima.
  • Temperatura Mínima.
  • Umidade Máxima.
  • Umidade Mínima.
  • Velocidade Média do Vento.
  • Radiação Global.

Obs.Caso o usuário não informe as variáveis abaixo as mesmas serão estimadas ou são adotados os valores padrão.

  1. Altura Anemômetro adotado valor dois.
  2. Radiação Líquida ela é estimada através da Radiação Global.
  3. Pressão Estimada através da altitude.
  4. Fluxo de Calor adotado valor Zero.
  5. Coeficiente de Cultura quando não informado a variável é ignorada.

Os campos que forem obrigatórios, e não forem preenchidos, serão marcados com um X vermelho para sinalizá-lo. Enquanto estes campos não forem preenchidos não será possível calcular a evapotranspiração.

Campo Obrigatório

Unidade de Medida

O usuário tem a flexibilidade de usar algumas unidades de medidas já pré-definidas pelo software. Independente da unidade de medida informada, o valor da evapotranspiração de referência será em milímetros por dia (mm.dia-1).

Unidade de Medidas

KC (Coeficiente de Cultura)

O Kc é o coeficiente de cultura e é usado para calcular a evapotranspiração real da cultura ETc, se não preenchido o software calcula apenas a evapotranspiração de referência.

Após informar os dados de entrada, click no botão aplicar [image] para efetuar o cálculo da evapotranspiração.

Resultado

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Lote

Instruções e Funções ›› Tipo de Processamento ››

Processamento em Lote

Para calcular a evapotranspiração de referência diária siga os passos abaixo.

Tipo de Processamento

Na parte superior direita do programa mude o tipo de processamento de individual para lote.

Tipo de Processamento

Localização

A localização é referente ao local que a estação estação agrometereológica está instalada. A latitude pode ser informada em graus ou em radianos e a altitude em metros.

Localização

Inserir dados de entrada Manual

1.Click com o com o botão direito do mouse sobre a grid.

Grid

2.No sub-menu escolha um das opções disponíveis

Sub-Menu

Insere uma linha na Grid, após este procedimento digite em cada coluna respectivamente o seu valor. Todos os campos são numéricos exceto a data que tem de ser informada no formato (dd/mm/yyyy) que ao sair da célula é validada neste formato e se a mesma é uma data válida.

Os campos numéricos somente aceitam digitos, ao pressionar outra tecla a mesma é ignorada pela célula, que quando está em foco (selecionada) fica na cor Laranja claro.

As variáveis citadas abaixo são obrigatórias para efetuar o cálculo da evapotranspiração Penman-Monteith FAO:

  • Data
  • Temperatura Máxima.
  • Temperatura Mínima.
  • Umidade Máxima.
  • Umidade Mínima.
  • Velocidade Média do Vento.
  • Radiação Global.

Obs.Caso o usuário não informe as variáveis abaixo as mesmas serão estimadas ou são adotados os valores padrão.

  1. Altura Anemômetro adotado valor dois.
  2. Radiação Líquida ela é estimada através da Radiação Global.
  3. Pressão Estimada através da altitude.
  4. Fluxo de Calor adotado valor Zero.
  5. Coeficiente de Cultura quando não informado a variável é ignorada.

Grid após inserção de uma linha

Exclui a linha selecionada da grid.

Setar unidade de medida para as variáveis agroclimáticas.

Importar arquivo contendo dados agroclimáticos. O Sistema para Manejo da Agricultura Irrigada importa arquivos de dados na extensão .xls;

Exclui todas as linhas da grid.

KC (Coeficiente de Cultura)

O kc é o coeficiente de cultura e é usado para calcular a evapotranspiração real da cultura ETc, se não preenchido o software calcula apenas a evapotranspiração de referência.

Após o preenchimento dos campos click no botão aplicar [image] para efetuar o cálculo da evapotranspiração.

Resultado processamento em Lote

O sistema emitirá uma mensagem dizendo quantas linhas foram processadas e com dois botões:

  • SIM: É gerado um relatório com os dados de entrada do usuário e o cálculo da evapotranspiração.
  • Não: O resultado do cálculo é mostrado apenas na grid, porém a qualquer momento o usuário pode gerar o relatório basta clicar no botão

Inserir dados de entrada através de arquivo

1. Click com o com o botão direito do mouse sobre a grid.

2. Importar arquivo.

3. Selecione o arquivo desejado.

Selecionando Arquivo.

4.Selecione a Planilha desejada.

Planilhas do arquivo

5.Após selecionar a planilha e clicar no botão [image] , o sistema carregara todos os dados da planilha para a grid, depois deste processo o usuário pode alterar os dados da planilha na própia grid , acrescentar mais linhas, excluir linhas e até importar outro arquivo.

Grid importada de um arquivo

6. Após todos os dados importados, o usuário deverá setar a unidade de dados, ou seja, informar qual a unidade de medida que se encontra a sua variável climática através do ícone [image] .

Unidade de medida

7.Click no botão [image] para calcular a evapotranspiração.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Arquivo de Lote

Instruções e Funções ›› Tipo de Processamento ›› Lote ››

Arquivo de Lote

O arquivo em lote necessáriamente terá que atender os requisitos abaixo:

  1. O arquivo deve ser um arquivo .xls.
  2. As colunas contendo as variáveis climáticas tem que seguir a risca a Figura 1, a primeira coluna na A1 e a última na K1.
  3. As colunas que poderão fica em branco são Radiação Líquida, Pressão e Fluxo de calor e Kc como segue a Figura2.
  4. No diretório de instalação do Sistema para Manejo da Agricultura Irrigada contém um arquivo base chamado sample.xls que servirá como exemplo para confecção de outros arquivos, ou mesmo somente ser alterado os dados climáticos do usuário.

Figura 1

Figura2

Created with the Personal Edition of HelpNDoc: Full featured multi-format Help generator


Unidade de Medida

Instruções e Funções ›› Tipo de Processamento ›› Lote ››

Processamento em Lote / Unidade de Medida

Neste formulário o usuário pode escolher a unidade de medida que deseja trabalhar.

Unidade de Medida

Quando não informado a Radiação Líquida e/ou Pressão o sistema bloqueia a opção de escolha da unidade de medida dos mesmos. A Radiação Líquida é estimada em MJ.m2.dia-1 e a Pressão em KPa.

Obs.: O formulário de unidade de medida só pode ser aberto se a grid não estiver vazia, ou seja sem linhas inseridas.

Após escolher as unidades de medidas das variáveis, click em Aplicar [image] .

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Relatório

Instruções e Funções ›› Tipo de Processamento ›› Lote ››

Relatório

Após o preenchimento dos campos click no botão aplicar [image] para efetuar o cálculo da evapotranspiração.

O sistema emitirá uma mensagem dizendo quantas linhas foram processadas e com duas opções:

Resultado processamento em Lote

  • SIM: É gerado um relatório com os dados de entrada do usuário e o cálculo da evapotranspiração.
  • Não: O resultado do cálculo é mostrado apenas na grid, porém a qualquer momento o usuário pode gerar o relatório basta clicar no botão

Relatório

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator